IBM MQ メッセージング・プロバイダー・トピック接続ファクトリーの拡張プロパティー

このパネルを使用して、WebSphere® MQ メッセージング・プロバイダーで使用する選択済みトピック接続ファクトリーの拡張プロパティーを表示または変更します。これらの拡張プロパティーによって、IBM MQ メッセージング・プロバイダー宛先に行われる接続の動作を制御します。

IBM MQ トピック接続ファクトリーの拡張プロパティーを表示するには、 管理コンソールを使用して以下のステップを実行します。
  1. ナビゲーション・ペインで、「リソース」 > 「JMS」->「トピック接続ファクトリー」をクリックして、既存のトピック接続ファクトリーを表示します。
  2. 適宜、目次ペインで、「有効範囲」の設定を、 トピック接続ファクトリーが定義されているレベルに変更します。 有効範囲をこのように設定することにより、表示されるキュー接続ファクトリーのセットが制限されます。
  3. 作業の対象となるトピック接続ファクトリーの名前を選択します。
  4. 目次ペインで、「追加プロパティー」の下にある「拡張プロパティー」をクリックして、IBM MQ トピック接続ファクトリーの拡張プロパティーのリストを表示します。
「一般プロパティー」の下には、以下の 6 つの拡張プロパティー・グループがあります。

これらのグループに、必要な変更を加えてから、「適用」をクリックして、トピック接続ファクトリーに戻ります。

注: IBM MQ プロパティーを指定する場合には、以下の制限が適用されます。

IBM MQ トピック接続ファクトリーには、以下の拡張プロパティーがあります。

クライアント再接続オプション (Client Reconnect Options)

このプロパティーは、通信障害またはキュー・マネージャーの障害が発生した場合に、クライアント・モード接続を自動的に再接続するかどうかを指定します。 シン・クライアント環境または管理対象クライアント環境で接続ファクトリーが使用されていない限り、このパラメーターは無視されます。

通知 値
データ型 ドロップダウン・リスト
デフォルト DISABLED
範囲
DISABLED
クライアントの再接続は自動的には実行されません。
ASDEF
クライアント構成ファイルのチャネル・スタンザで設定する DefRecon 属性からの値を使用します。 クライアント構成ファイルで DefRecon 値が指定されていない場合、ASDEF は DISABLED と同じ効果があります。
QMGR
最初に接続が確立されていたキュー・マネージャーにのみ再接続されます。
RECONNECT
キュー・マネージャー属性の値と一致するキュー・マネージャーに再接続します。 このキュー・マネージャーは、最初に接続が確立されていたキュー・マネージャーとは異なっている可能性があります。

自動クライアント再接続について詳しくは、IBM MQ インフォメーション・センターを参照してください。

クライアント再接続タイムアウト

通信障害またはキュー・マネージャーの障害発生後、クライアント・モード接続がキュー・マネージャーへの自動再接続の試行に費やす最大秒数。 シン・クライアント環境または管理対象クライアント環境で接続ファクトリーが使用されていない限り、このパラメーターは無視されます。このパラメーターが使用されるかどうかは、クライアント再接続オプションのパラメーターの値によって異なります。

通知 値
データ型 整数
単位 秒
デフォルト 1800 (30 分)
範囲 ゼロより大きく 2147483647 以下の値。

自動クライアント再接続について詳しくは、IBM MQ インフォメーション・センターを参照してください。

メッセージ・ヘッダーの圧縮

メッセージ・ヘッダーの圧縮を使用可能にするオプション。

通知 値
データ型 チェック・ボックス
デフォルト クリア
範囲
クリア
メッセージ・ヘッダーを圧縮しません。
選択
メッセージ・ヘッダーの圧縮

メッセージ・ペイロードの圧縮アルゴリズム

メッセージ・ペイロードの圧縮に使用する圧縮アルゴリズム。

通知 値
データ型 ドロップダウン・リスト
デフォルト NONE
範囲
RLE
ラン・レングス・エンコードを使用してメッセージ・データ圧縮を実行します。
ZLIBFAST
速度優先の ZLIB エンコードを使用してメッセージ・データ圧縮を実行します。
ZLIBHIGH
圧縮優先の ZLIB エンコードを使用してメッセージ・データ圧縮を実行します。
NONE
メッセージ・データ圧縮は実行されません。

一時トピック接頭部

一時トピックで生成される名前の先頭に付加される接頭部。

通知 値
データ型 ストリング

ポーリング間隔

この設定は、クライアント・コンテナーにのみ適用できます。 IBM MQ バージョン 6 キュー・マネージャー (または IBM MQ for z/OS® バージョン 5.3) を使用する場合、この設定は JMS 非同期コンシューマーにメッセージをディスパッチするのに使用するメカニズムを構成します。

非同期にコンシュームされている IBM MQ のキュー・セットが、IBM MQ キューからのメッセージを内部で同期的に取得可能なスレッドの数を超えた場合、この設定が使用されます。セット内の別の IBM MQ キューをポーリングする前に、IBM MQ キューへのメッセージ到着をスレッドが待機する時間の長さを、この設定によって決定します。

通知 値
データ型 整数
単位 ミリ秒
デフォルト 5000
範囲 ゼロより大きい値。

最大バッチ・サイズ

非同期コンシューマーに少なくとも 1 つ送達する前に、キューから除去できるメッセージの最大数。

通知 値
データ型 整数
デフォルト 10
範囲 ゼロより大きい値。

コード化文字セット ID

メッセージ内のストリングをエンコードするときに使用する文字セット。

通知 値
データ型 整数
デフォルト 819
範囲 ゼロより大きい値。このコード化文字セット ID (CCSID) は、IBM MQ でサポートされている CCSID のいずれかである必要があります。

サポートされる CCSID についての詳細、およびあるコード化文字セットから別のコード化文字セットへのメッセージ・データの変換については、IBM MQ インフォメーション・センターの「システム管理」および「アプリケーション・プログラミング・リファレンス」のセクションを参照してください。

IBM MQ メッセージング・プロバイダー のキュー・マネージャーが静止した場合に JMS メソッド呼び出しを失敗させる

キュー・マネージャーが静止状態になった場合に、選択した JMS 操作が失敗するようにするオプション。このオプションを選択すると、キュー・マネージャーが正常に静止したり、シャットダウンしたりできるようになります。

通知 値
データ型 チェック・ボックス
デフォルト 選択
範囲
クリア
キュー・マネージャーが静止した場合に JMS 操作を失敗させません。
選択
キュー・マネージャーが静止した場合に JMS 操作を失敗させます。


ファイル名: umj_ptcfm_advprops.html