Utilice esta página para ver y configurar un canal de transporte HTTP. Este tipo de canal de transporte maneja las solicitudes HTTP de un cliente remoto.
Un canal de transporte HTTP analiza las solicitudes HTTP y busca un canal de aplicación adecuado para manejar la solicitud y enviar una respuesta.
Para ver esta página de la consola de administración, pulse nombre_servidor > Puertos. Localice el puerto del canal HTTP cuyos valores desea ver o configurar y pulse Ver transportes asociados. Pulse el nombre de la cadena de transporte que incluye este transporte HTTP y, a continuación, pulse el nombre del canal de transporte HTTP.
Especifica el nombre del canal de transporte HTTP.
El campo de nombre no puede contener ninguno de los caracteres siguientes: # \ / , : ; " * ? < > | = + & % '
Este nombre debe ser exclusivo en todos los canales del sistema. Por ejemplo, un canal de transporte HTTP y un canal de transporte TCP no pueden tener el mismo nombre si residen dentro del mismo sistema.
| Información | Valor |
|---|---|
| Tipo de datos | Serie |
Especifica la prioridad que este canal tiene en relación a otros canales en esta cadena de transporte. Esta propiedad sólo se utiliza cuando está habilitado el compartimiento de puertos y la cadena de transporte incluye varios canales a los que puede reenviar datos. El canal de la cadena que tiene el peso de discriminación más bajo es el canal primero que examina los datos de entrada y determina si es propietario de dichos datos.
| Información | Valor |
|---|---|
| Tipo de datos | Entero positivo |
| String | 0 |
Para usuarios de transición: En versiones anteriores, una excepción de tipo "Ha fallado la discriminación" en el Canal HTTP devuelve un código de respuesta 403. En Versión 8.5, el servidor devuelve un código de respuesta 500. trnsEspecifica la cantidad de tiempo, en segundos, que el canal de transporte HTTP espera a que termine una solicitud de lectura en un socket después de producirse la primera lectura. La lectura que se espera puede formar parte del cuerpo de la solicitud de lectura, por ejemplo POST, o parte de las cabeceras, si todas las cabeceras no se leen como parte de la primera lectura que se produce en el socket para esta solicitud.
| Información | Valor |
|---|---|
| Tipo de datos | Entero |
| String | 60 segundos |
Especifica la cantidad de tiempo, en segundos, que el canal de transporte HTTP espera en un socket a que se transmita cada parte de los datos de respuesta. Normalmente este tiempo de espera sólo se produce en situaciones en las que las grabaciones se quedan atrás de las solicitudes nuevas. Esta situación se puede producir cuando un cliente tiene un índice de datos lento o cuando la NIC (Network Interface Card) del servidor está saturada con E/S.
Si algunos de los clientes requieren más de 300 segundos en recibir los datos que se están grabando para ellos, cambie el valor especificado para el parámetro Tiempo de espera de grabación. Algunos clientes son lentos y necesitan más de 300 segundos para recibir los datos que se les envían. Para garantizar que pueden obtener todos los datos, cambie el valor especificado para este parámetro en un período de tiempo en segundos que sea suficiente para poder recibir todos los datos. Asegúrese de que, si cambia este valor, el nuevo valor siga protegiendo al servidor ante clientes malintencionados.
| Información | Valor |
|---|---|
| Tipo de datos | Entero |
| String | 60 segundos |
Especifica la cantidad de tiempo, en segundos, que el canal de transporte HTTP permite que un socket permanezca desocupado entre solicitudes.
| Información | Valor |
|---|---|
| Tipo de datos | Entero |
| String | 30 segundos |
Cuando se selecciona, especifica que las conexiones del canal de transporte HTTP se dejan abiertas entre las distintas solicitudes. Si se dejan abiertas las conexiones se puede ahorrar configuración y reducir costes de sockets si la carga de trabajo tiene clientes que envían muchas solicitudes.
Si los clientes sólo envían peticiones individuales durante períodos prolongados de tiempo, es probable que lo mejor sea inhabilitar esta opción y cerrar las conexiones directamente en lugar de que sea el canal de transporte HTTP el que configure el valor de tiempo de espera excedido para cerrar la conexión posteriormente.
El valor predeterminado es true y es habitualmente el valor óptimo.
Evite problemas: Si se especifica un valor distinto de 0 para la propiedad de peticiones persistentes máximas, se hace caso omiso del valor de la propiedad Utilizar conexiones persistentes (mantener activado).gotchaSi se selecciona, especifica que el número de peticiones persistentes por conexión no tiene límite.
Si se selecciona, especifica que el número de solicitudes persistentes por conexión se limita al número especificado para la propiedad Número máximo de solicitudes persistentes. Este valor de propiedad se ignora si no se habilita la propiedad Utilizar conexiones persistentes (mantener activas).
Cambie el valor especificado para el parámetro de número máximo de solicitudes persistentes de modo que se aumente el número de solicitudes que pueden fluir a través de una conexión antes de cerrarla. Cuando se ha habilitado la opción Utilizar conexiones persistentes, el parámetro Máximo de peticiones persistentes controla el número de peticiones que pueden fluir a través de una conexión antes de que se cierre. El valor por omisión es 100. Este valor debe establecerse en un valor tal que la mayor parte de los clientes, si no todos, tengan siempre una conexión abierta cuando realizan varias peticiones durante la misma sesión. Si este parámetro se establece en un valor correcto se evita la configuración y supresión innecesaria de sockets.
Para los escenarios de prueba en los que el cliente nunca cerrará un socket o donde los sockets siempre son servidores proxy o web delante del servidor de aplicaciones, un valor de -1 inhabilita el proceso, que limita el número de solicitudes en una sola conexión. El tiempo de espera persistente cierra de todas formas algunos sockets desocupados y evita que el servidor se quede sin sockets abiertos.
Especifica el número máximo de solicitudes persistentes que se permiten en una sola conexión HTTP. Puede añadir un valor en este campo sólo si la propiedad Solicitudes persistentes máximas por conexión está seleccionada.
Cuando se ha habilitado la opción Utilizar conexiones persistentes, el parámetro Máximo de peticiones persistentes controla el número de peticiones que pueden fluir a través de una conexión antes de que se cierre. El valor por omisión es 100. Este valor debe establecerse en un valor tal que la mayor parte de los clientes, si no todos, tengan siempre una conexión abierta cuando realizan varias peticiones durante la misma sesión. Si este parámetro se establece en un valor correcto se evita la configuración y supresión innecesaria de sockets.
Para los escenarios de prueba en los que el cliente nunca cerrará un socket o donde los sockets siempre son servidores proxy o web delante del servidor de aplicaciones, un valor de -1 inhabilitará el proceso que limita el número de solicitudes en una sola conexión. El tiempo de espera persistente cerrará de todas formas algunos sockets desocupados y evitará que el servidor se quede sin sockets abiertos.
Si se especifica un valor de 0 o 1, únicamente se permite una petición por conexión.
| Información | Valor |
|---|---|
| Tipo de datos | Entero |
| String | 100 |
Especifica, en bytes, el tamaño máximo para una cabecera que se puede incluir en una petición HTTP.
El establecimiento de esta propiedad en un tamaño realista para las aplicaciones ayuda a evitar ataques de denegación de servicio (DoS) que utilizan grandes cabeceras en una solicitud HTTP como intento para dejar un recurso de sistema, por ejemplo las aplicaciones que manejan solicitudes HTTP, básicamente no disponibles para los usuarios previstos.
El valor predeterminado para esta propiedad es 32768 bytes.
Especifica el número máximo de cabeceras que se pueden incluir en una sola solicitud HTTP.
Establecer esta propiedad en un número realista para las aplicaciones le ayuda a evitar ataques de denegación de servicios (DoS) que utilizan un gran número de cabeceras en una petición HTTP como intento de realizar un recurso de sistema como, por ejemplo, las aplicaciones que procesan peticiones HTTP, básicamente no disponibles para sus usuarios previstos.
El valor predeterminado para esta propiedad es 50.
Evite problemas: Incluso aunque no cambie el valor de esta propiedad, cuando utilice esta página de la consola de administración para cambiar otros valores del canal de transporte HTTP, el valor especificado para esta propiedad cuando lleve a cabo una acción de guardar se efectuará automáticamente en la propiedad correspondiente del archivo server.xml. Este cambio alterará temporalmente cualquier valor que ha establecido anteriormente para esta propiedad en el archivo server.xml incluso si no tiene la intención de actualizar el valor actual de esta propiedad en el archivo server.xml. gotchaSi se selecciona, especifica que el tamaño del cuerpo de una solicitud HTTP está limitado.
Esta propiedad puede utilizarse para evitar ataques de denegación de servicio que utilizan solicitudes HTTP grandes como intento de dejar un recurso de sistema, por ejemplo las aplicaciones que procesan solicitudes HTTP, básicamente no disponibles para los usuarios previstos.
Especifica, en bytes, el límite de tamaño máximo del cuerpo de una solicitud HTTP. Si se excede este tamaño, la solicitud no se procesa.
Puede añadir un valor en este campo sólo si se selecciona la propiedad Limitar tamaño de almacenamiento intermedio de cuerpo de solicitud.
Puede utilizar los valores de esta sección para configurar y habilitar las anotaciones de acceso National Center for Supercomputing Applications (NCSA) o anotaciones de errores HTTP. Si ejecuta el producto en z/OS, también puede utilizar esta sección para configurar y habilitar el registro cronológico Fast Response Cache Accelerator (FRCA). Si se habilita cualquiera de estos servicios de registro cronológico, disminuirá el rendimiento del servidor.
Si desea que cualquiera de los servicios de anotaciones habilitados se inicie cuando arranque el servidor, pulse nombre_servidor. A continuación, en la sección de resolución de problemas, pulse Registro cronológico de errores HTTP, accesos de NCSA y de FRCA y seleccione Habilitar el servicio de registro cronológico en el arranque de servidor. Cuando se selecciona esta opción, cualquier servicio de errores HTTP, NCSA o FRCA que esté habilitado se inicia automáticamente cuando se inicia el servidor.
Evite problemas: Si ejecuta el producto en z/OS, los valores de las anotaciones de errores HTTP, accesos NCSA y FRCA deben especificarse en el controlador. Estos valores se ignoran si
se especifican en el sirviente o adjunto.gotchaDe forma predeterminada se selecciona la opción Utilizar servicio de anotaciones globales para las anotaciones de acceso NCSA. Este valor significa que los valores de registro cronológico de acceso NCSA toman de forma predeterminada los valores especificados para el registro cronológico de acceso NCSA en la página Registro cronológico de errores de HTTP, accesos de NCSA y FRCA de la consola de administración. Si desea cambiar los valores de este canal de transporte HTTP específico, expanda la sección Registro cronológico de acceso NCSA y seleccione la opción Utilizar registro cronológico específico de cadena.
Cuando se selecciona, se conserva un registro de solicitudes de cliente de entrada que maneja el canal de transporte HTTP se conserva en el archivo de registro de acceso NCSA.
Especifica el nombre y la vía de acceso del directorio del archivo de registro cronológico de acceso NCSA. Al especificar la vía de acceso de directorio pueden utilizarse sustituciones de variables como $(SERVER_LOG_ROOT).
Si ejecuta el producto en z/OS, debe utilizar una variable específica de servidor, como $(SERVER_LOG_ROOT), para evitar colisiones en el nombre del archivo de anotaciones.
Especifica el tamaño máximo, en megabytes, del archivo de registro cronológico de acceso NCSA. Cuando se alcanza este tamaño, se crea el archivo de registro cronológico denominado nombre_archivo_registro_cronológico. No obstante, cada vez que el archivo de anotaciones cronológicas cronológico original se desborda, la versión más actual del archivo original se escribirá encima de este archivo archivador.
Especifica el número máximo de versiones históricas del archivo de registro de acceso NCSA que se mantienen para una referencia futura.
Especifica el formato en el que aparece la información de acceso de cliente en el archivo de anotaciones NCSA. Si selecciona Común, las entradas de registro cronológico contienen el recurso solicitado y otras pocas partes de información, pero no contienen información de referencia, de agente de usuario y de cookies. Si se selecciona Combinado, se incluye información de referencia, de agente de usuario y de cookies.
De forma predeterminada se selecciona la opción Utilizar servicio de anotaciones globales para las anotaciones FRCA. Este valor significa que los valores de registro FRCA toman de forma predeterminada los valores especificados para el registro FRCA en la página deerror HTTP, acceso de NCSA y registro FRCA de la consola de administración. Si desea modificar los valores de este canal de transporte HTTP específico, expanda la sección Anotaciones FRCA y seleccione la opción Utilizar anotaciones específicas de cadena.
Este campo sólo aparece si se está ejecutando el producto en z/OS.
Cuando se selecciona, se conserva un registro de solicitudes de cliente de entrada que maneja el canal de transporte HTTP se conserva en el archivo de registro FRCA.
Este campo sólo aparece si se está ejecutando el producto en z/OS.
Especifica el nombre y la vía de acceso del directorio del archivo de anotaciones FRCA. Utilice una variable específica de servidor, como $(SERVER_LOG_ROOT), para impedir conflictos de nombre de archivo.
Este campo sólo aparece si se está ejecutando el producto en z/OS.
Especifica el tamaño máximo, en megabytes, del archivo de registro cronológico FRCA. Cuando se alcanza este tamaño, se crea el archivo de registro cronológico denominado nombre_archivo_registro_cronológico. No obstante, cada vez que el archivo de anotaciones cronológicas cronológico original se desborda, la versión más actual del archivo original se escribirá encima de este archivo archivador.
Este campo sólo aparece si se está ejecutando el producto en z/OS.
Especifica el número máximo de versiones históricas del archivo de anotaciones FRCA que se mantienen para una referencia futura.
Este campo sólo aparece si se está ejecutando el producto en z/OS.
Especifica el formato en el que aparece la información de acceso de cliente en el archivo de registro cronológico FRCA. Si selecciona Común, las entradas de registro cronológico contienen el recurso solicitado y otras pocas partes de información, pero no contienen información de referencia, de agente de usuario y de cookies. Si se selecciona Combinado, se incluye información de referencia, de agente de usuario y de cookies.
Este campo sólo aparece si se está ejecutando el producto en z/OS.
De forma predeterminada, la opción Utilizar servicio de registro cronológico global está seleccionada para el registro de errores. Este valor indica que los valores de registro cronológico de errores toman de forma predeterminada los valores que se han especificado para el registro cronológico de errores en la página Registro cronológico de errores HTTP, accesos NCSA y FRCA de la consola de administración. Si desea cambiar estos valores de este canal de transporte HTTP específico, expanda la sección Registro cronológico de errores y seleccione la opción Utilizar registro cronológico específico de cadena.
Cuando se selecciona, los errores HTTP que se producen mientras el canal HTTP procesa peticiones de cliente se anotarán en el archivo de anotaciones de errores HTTP.
Indica la vía de acceso de directorio y el nombre del archivo de registro cronológico de errores HTTP. Al especificar la vía de acceso de directorio pueden utilizarse sustituciones de variables como $(SERVER_LOG_ROOT).
Si ejecuta el producto en z/OS, debe utilizar una variable específica de servidor, como $(SERVER_LOG_ROOT), para evitar colisiones en el nombre del archivo de anotaciones.
Indica el tamaño máximo, en megabytes, del archivo de registro cronológico de errores. Cuando se alcanza este tamaño, se crea el archivo de registro cronológico denominado nombre_archivo_registro_cronológico. No obstante, cada vez que el archivo de registro cronológico original se desborda, la versión más actual del archivo original se escribirá encima de este archivo archivador.
Especifica el número máximo de versiones históricas del archivo de registro cronológico de errores HTTP que se guardan para su consulta futura.
Especifica el tipo de mensajes de error que se incluyen en el archivo de anotaciones de errores HTTP.