프록시 서버 설정

이 주제를 사용하여 프록시 서버에서 고급 구성을 수행하십시오. 프록시 설정을 사용하여 시스템 관리자가 프록시 서버의 작동을 조정할 수 있습니다. 특히, 애플리케이션 서버에 연결 및 요청을 구성하고 캐싱을 사용 가능하게 하며 거부되어야 하는 요청을 구성하고 오류 응답이 처리되는 방법을 정의하며 프록시 로그의 위치를 지정할 수 있습니다.

작성 시 프록시 서버는 환경을 자동 감지하고 제품에 요청을 라우팅할 수 있습니다. 특정 환경의 요구에 맞게 추가 구성을 프록시 서버에 적용할 수 있습니다.

이 관리 콘솔 페이지를 보려면 서버 > 서버 유형 > WebSphere 프록시 서버 > proxy_server_name > HTTP 프록시 서버 설정 > 프록시 설정을 클릭하십시오.

문제점 방지 문제점 방지: 작성한 프록시 서버가 프록시 서버 클러스터의 일부인 경우 프록시 서버 레벨에서 수정할 수 있는 유일한 HTTP 프록시 서버 설정은 로컬 아웃바운드 TCP 주소입니다. 다른 HTTP 프록시 서버 설정은 프록시 클러스터 레벨에서 설정되어야 합니다. 프록시 서버 클러스터의 일부인 프록시 서버를 구성하는 방법에 대한 정보는 프록시 서버 클러스터 수정 및 프록시 클러스터 멤버 설정 주제를 참조하십시오. gotcha

구성 탭에서 프록시 서버의 구성 가능 필드 설정을 편집할 수 있습니다.

웹 서비스 지원 사용 가능

프록시 서버가 웹 서비스 통신량을 라우트하도록 할지 여부를 지정합니다.

정보 값
데이터 유형 부울
기본값 True

제외

프록시 서버는 모든 수신 요청을 검사합니다. 제외에 대한 일부 메소드를 정의할 수 있으며 요청 HTTP 메소드가 제외에 대해 구성된 메소드와 일치하는 경우, 프록시 서버가 METHOD DISALLOWED 오류를 발생시키며 요청을 거부합니다. 각 메소드를 단일 행으로 입력하십시오.

정적 라우팅 파일 디렉토리

정적 라우팅 파일이 있는 프록시 서버의 디렉토리를 지정합니다.

정보 값
데이터 유형 String
기본값 profile_home/staticRoutes

HTTP 메소드 사용 불가능

프록시 서버에 대해 사용 불가능한 HTTP 메소드 목록을 지정합니다. 이 설정을 사용 가능하도록 하려면 선택란을 선택하십시오. 목록에서 HTTP 메소드를 추가 또는 제거하려면 새로 작성 또는 삭제를 클릭하십시오.

정보 값
데이터 유형 String
기본값 공백

아웃바운드 연결 설정

프록시 서버와 컨텐츠 서버 사이에 기본 HTTP 연결 매개변수를 지정합니다.

아웃바운드 요청 읽기 제한시간
프록시 서버가 컨텐츠 서버에 대한 요청 제한시간을 초과하기 전에 응답을 기다리는 기본 시간(초)을 지정합니다. 값을 변경할 경우 주의하여 이 옵션을 고려하십시오.
아웃바운드 요청 쓰기 제한시간
프록시 서버가 컨텐츠 서버에 대한 쓰기 요청을 기다리는 기본 시간(초)을 지정합니다. 값을 변경할 경우 주의하여 이 옵션을 고려하십시오.
아웃바운드 연결 제한시간
프록시 서버가 서버에 연결될 때까지 기다리는 밀리초 수를 지정합니다. 해당 시간이 만기될 경우, 프록시 서버는 다른 서버에 연결을 시도합니다. 다른 사용 가능한 서버가 존재하지 않을 경우, 요청 제한시간이 초과됩니다. 값이 0이면 프록시 서버에서 운영 체제 커널 제한시간 값을 사용해야 함을 나타냅니다.
컨텐츠 서버에 대한 연결 풀링
서버에 대한 연결을 풀링하는 옵션이 최적화 기능되도록 지정합니다. 풀링은 프록시 서버가 서버로의 소켓 연결을 풀링하고 해당 연결을 다시 사용하도록 하여 서버로의 소켓 연결을 자주 작성하고 해제할 필요를 방지합니다.
서버당 최대 연결 수
단일 컨텐츠 서버에 풀링될 최대 연결 수를 지정합니다.
로컬 아웃바운드 TCP 주소
SIP 컨테이너에 들어오고 나가는 데이터의 로컬 아웃바운드 TCP 주소를 지정합니다. 이 설정값은 네트워크가 분할된 경우 SIP 프록시와 SIP 컨테이너 간의 모든 통신에 사용할 호스트 이름 또는 IP 주소입니다.
정보 값
데이터 유형 String
기본값 *
범위 IP 주소 또는 유효한 호스트 이름
다음 프록시 사용자 정의 특성은 아웃바운드 연결을 조정하는 데 사용할 수 있습니다.
  • key=http.maxTargetReconnects: 요청마다 동일 대상 컨텐츠 서버에 대한 최대 재연결 수. 기본값은 5입니다.
  • key=http.maxTargetRetries: 요청마다 프록시가 새 대상 컨텐츠 서버를 선택하려고 시도한 최대 횟수. 기본값은 5입니다.
  • key=http.routing.sendReverseProxyNameInHost: WebSphere® Application Server 컨텐츠 서버에 없는 컨텐츠에 대해 호스트 헤더를 재작성할지 여부를 판별합니다. 옵션은 true 또는 false이며 대소문자가 구분되지 않습니다. 이 특성의 값이 기본 설정인 false이면 호스트 헤더가 대상 서버의 호스트로 다시 작성됩니다. 이 특성의 값이 true이면 호스트 헤더가 다시 작성되지 않습니다.
  • key=http.compliance.disable: 프록시 컨텐츠 서버 연결에 대해 HTTP V1.1을 준수해야 하는지 여부를 판별합니다. 옵션은 true 또는 false이며 대소문자가 구분되지 않습니다. 기본값은 false입니다.
  • key=http.compliance.via: HTTP 준수에 대해 요청 및 응답에 추가되는 매개 헤더 값. 값이 널이면 매개 헤더는 추가되지 않습니다. 값이 true이면 기본 매개 값이 추가됩니다. 그렇지 않으면, 지정된 문자열 매개 값이 추가됩니다. 기본값은 널입니다.

인바운드 연결 SSL 구성

몇 가지 소스 중 하나로부터 SSL 구성을 지정합니다.

중앙 관리
선택하면 해당 엔드포인트에 범위가 지정된 SSL 구성을 사용합니다.
이 엔드포인트에만 해당됨
선택하면 SSL 구성 선택 목록을 사용할 수 있습니다.
SSL 구성 선택
미리 정의된 SSL 구성을 지정합니다.
정보 값
데이터 유형 String
기본값 없음
범위 없음, CellDefaultSSLSettings 또는 NodeDefaultSSLSettings

캐싱

프록시 서버가 서버의 컨텐츠를 캐시하도록 할지 여부를 지정합니다.

캐시 사용 가능을 선택하면 HTTP 1.1 스펙에 정의된 대로 프록시 서버에 대한 정적 컨텐츠 캐싱을 사용 가능하게 합니다. 기본적으로, 컨텐츠 캐싱이 사용 가능합니다.

다음 특성은 캐싱이 사용 가능한 경우에만 적용됩니다.
캐시 인스턴스 이름
모든 정적 및 동적 컨텐츠 응답을 캐시하는 데 사용되는, 자원 > 캐시 인스턴스 > 오브젝트 캐시 인스턴스에서 구성된 동적 캐시 오브젝트 캐시 인스턴스를 지정합니다. 이 오브젝트 캐시 인스턴스는 새 I/O(NIO) API(Application Program Interface)를 지원하도록 구성해야 합니다.
SSL 내용 캐시
프록시 서버가 종료한 클라이언트 프록시 서버 SSL 연결에서 응답을 캐시해야 하는지 여부를 판별합니다.
적극적 캐시
정상적으로 캐시되지 않는 HTTP 응답의 캐싱을 사용 가능하게 합니다. HTTP 1.1에서 정의된 캐싱 규칙은 캐싱 최적화를 위해 중단할 수 있습니다.
동적 내용 캐시
WebSphere Application Server V6.02 이상에서 생성된 동적 컨텐츠가 캐시되는지 여부를 판별합니다. WebSphere Application Server V6.02 이전에 컨텐츠 서버에서 생성된 동적 컨텐츠를 캐시하는 것은 지원되지 않습니다.
메모리 캐시 항목 크기 제한
선택하면 메모리 캐시 항목 크기를 사용할 수 있습니다.
메모리 캐시 항목 크기
캐시된 개별 응답의 최대 크기(MB)를 지정합니다. 이 값보다 큰 캐시된 모든 응답은 캐시되지 않습니다.

로깅

프록시 서버에는 프록시 및 저장된 캐시 요청을 위해 생성된 로그가 있습니다. 액세스 로깅 사용 가능을 선택하면 액세스 로그의 크기 및 위치를 지정할 수 있습니다.

액세스 로그 최대 크기
액세스 로그의 최대 크기(MB)를 지정합니다.
정보 값
데이터 유형 Integer
단위 MB
기본값 500
프록시 액세스 로그
프록시 액세스 로그의 디렉토리 위치를 지정합니다.
정보 값
데이터 유형 String
기본값 ${SERVER_LOG_ROOT}/proxy.log
캐시 액세스 로그
캐시 액세스 로그의 디렉토리 위치를 지정합니다.
정보 값
데이터 유형 String
기본값 ${SERVER_LOG_ROOT}/cache.log
로컬 액세스 로그
로컬 액세스 로그의 디렉토리 위치를 지정합니다.
정보 값
데이터 유형 String
기본값 ${SERVER_LOG_ROOT}/local.log
참고: 로컬로 제공되는 프록시 컨텐츠를 로그하는 ${SERVER_LOG_ROOT}/local.log 로그가 있습니다. 이 컨텐츠는 프록시 캐시에 없습니다.
HTTP 요청은 세 가지 로그(프록시, 캐시 및 로컬) 중 하나에 로그됩니다. 로컬 로그 구성은 현재 관리 콘솔에서 사용할 수 없고, ${SERVER_LOG_ROOT}/local.log에서 사용 가능합니다. http.log.localFileName 사용자 정의 특성을 파일 위치에 설정하여 이 로그의 위치를 지정하십시오. 각 로그의 내용은 NCSA(National Center for Supercomputing Applications) 공통 로그 형식을 사용하여 형식화됩니다.
  • 프록시 액세스 로그: 원격 서버에서 수신된 응답을 로그합니다.
  • 캐시 액세스 로그 : 로컬 캐시에서 제공되는 응답을 로그합니다.
  • 로컬 액세스 로그: 경로 재지정 및 내부 오류와 같은 비캐시 로컬 응답을 로그합니다.
로깅을 미조정하기 위해 사용할 수 있는 프록시 사용자 정의 특성은 다음과 같습니다.
  • key=http.log.disableAll: 이 특성은 모든 로깅을 사용 불가능하게 합니다. true 값은 프록시, 캐시 및 로컬 로깅을 중지합니다.
  • key=http.log.maxSize: MB 단위의 최대 로그 크기. UNLIMITED 값은 제한 없음을 표시합니다.
  • key=http.log.localFileName: 로컬 로그의 이름을 포함합니다. NULL 값은 기본값 ${SERVER_LOG_ROOT}/local.log가 사용됨을 표시합니다.

보안

이 섹션을 사용하여 보안 옵션을 설정하십시오.

프록시 마스크 서버 헤더 사용
선택하면 컨텐츠 서버의 이름을 클라이언트로 전달하도록 지정합니다.
백엔드 서버 헤더 사용
선택하면 기본 서버 이름이 컨텐츠 서버 이름으로 전송되도록 지정합니다.
서버 헤더 값 지정
선택하면 서버 헤더 설정을 사용할 수 있습니다.
서버 헤더
HTTP 응답에 사용되는 서버 이름을 지정합니다.
신뢰된 보안 프록시
프록시 서버 이외의 매개체에서 요청을 처리하도록 지정합니다. 이 설정은 어떤 프록시 서버를 신뢰할 수 있는지 식별합니다. WebSphere Application Server 플러그인 클라이언트는 전달하는 요청에 개인 헤더를 추가합니다. 프록시 서버의 경우 해당 헤더를 사용하려면 요청은 신뢰된 보안 프록시 중 하나에서 와야 합니다. 요청이 신뢰된 보안 프록시 중 하나에서 오지 않는 경우 해당하는 개인 헤더는 프록시 서버가 요청을 전달하기 전에 무시되며 요청에서 제거됩니다. 이 필드에서 IP 또는 완전한 호스트 이름을 사용하십시오.WebSphere Application Server 플러그인 클라이언트가 실행 중인 시스템에 다중 IP 주소가 있는 경우 신뢰된 목록의 값은 해당 시스템의 아웃바운드 연결 IP 주소와 일치해야 합니다. 연결의 플러그인측에서 사용하는 IP 주소를 모르는 경우, 아웃바운드 연결에서 프록시 서버에 대해 어떤 IP 주소가 사용되더라도 IP 주소가 신뢰된 목록의 IP 주소 중 하나와 일치하도록 해당 시스템에 대해 모든 IP 주소를 지정해야 합니다.
보안 프록시를 사용하려면 이 선택란을 선택하십시오. 목록에서 프록시를 추가 또는 제거하려면 새로 작성 또는 삭제를 클릭하십시오.
참고: 기본값인 신뢰된 보안 프록시 목록이 비어 있는 것은 WebSphere Application Server 플러그인 클라이언트가 신뢰되지 않는다는 것을 나타냅니다.
정보 값
데이터 유형 String
기본값 공백
범위 IP 주소 또는 유효한 호스트 이름

프록시 플러그인 구성 정책

이 섹션을 사용하여 프록시 플러그인을 구성합니다.

플러그인 구성 생성
프록시 서버 앞에서 배치되는 웹 서버에서 사용할 수 있는 프록시 플러그인 구성 파일의 생성을 지정합니다. 플러그인이 애플리케이션 서버 대신 프록시가 처리할 URI를 판별할 수 있습니다. 플러그인이 프록시의 경계 또는 엔드포인트를 판별하여 수신하는 요청을 프록시에 적절히 라우팅할 수 있습니다.
플러그인 생성에 사용 가능한 옵션은 다음 표에 설명되어 있습니다.
범위 설명
없음 범위 없음
모두 프록시 서버는 코어 그룹 브릿지로 연결된 로컬 셀 및 모든 셀에서 프록시 서버가 처리하는 모든 URI를 포함하는 플러그인 구성 정보를 생성합니다.
셀 셀의 모든 프록시 서버에서 처리되는 모든 URI를 포함하는 플러그인 구성을 프록시 서버가 생성합니다.
노드 노드에 대해 구성된 모든 URI를 포함합니다.
서버 프록시 서버는 현재 구성된 프록시 서버에 대한 플러그인 구성 파일만을 생성합니다.
플러그인 구성 변경 스크립트
WebSphere Application Server 플러그인 구성이 생성된 후 실행되는 스크립트에 대한 경로를 지정합니다.

사용자 정의 오류 페이지 정책

이 섹션을 사용하면 요청 처리 중 오류가 발생할 경우 오류 설정 페이지를 구성할 수 있습니다.

기본적으로 어떤 사용자 정의 오류 페이지도 생성할 수 없습니다.
로컬 오류 페이지 처리
로컬로 생성된 오류 응답을 애플리케이션으로 라우팅합니다. 두 가지 방법으로 오류를 처리하고 특정 오류 코드에 오류 맵핑을 지정할 수 있습니다.
  • 프록시 서버에서 생성된 오류를 처리합니다.
  • 애플리케이션 서버에서 생성된 오류를 처리합니다.
원격 오류 페이지 처리
선택하면, 프록시 서버가 생성하는 HTTP 응답 오류 상태 코드와 프록시 컨텐츠 서버 연결 오류에 대해 프록시가 응답한 후 다른 위치에서 생성되는 HTTP 응답 오류 상태 코드를 지정합니다. 선택하지 않으면 프록시 서버가 생성하는 HTTP 응답 오류 상태 코드가 처리됩니다. 우수 사례는 프록시 서버와 동일한 물리적 시스템에서 오류 페이지 애플리케이션을 구성하는 것입니다.
오류 페이지 생성 애플리케이션 URI
설치된 애플리케이션에 유효한 URL(Uniform Resource Locator)가 제공되면 사용자 정의 오류 페이지 정책을 사용할 수 있도록 지정합니다. 설치된 애플리케이션에 올바른 URI가 제공되지 않으면 사용자 정의 오류 페이지 정책에서 어떠한 요청도 처리하지 않습니다.두 가지 방법으로 오류를 처리할 수 있습니다.
  • 로컬로 생성된 오류 응답을 애플리케이션으로 라우팅합니다.
  • 원격 서버의 오류 응답을 오류 페이지 생성기 애플리케이션으로 라우팅합니다.
오류 페이지 애플리케이션으로 전달할 헤더
오류 페이지 애플리케이션에 조회 매개변수로 전달할 클라이언트 요청의 추가 헤더 값을 지정합니다. responseCode 및 URI 조회 매개변수는 구성된 애플리케이션 외에도 오류 페이지 애플리케이션에 항상 전송됩니다. responseCode 매개변수는 내부적으로 생성하거나 컨텐츠 서버에서 리턴하는 HTTP 상태 코드입니다. URI 매개변수는 클라이언트의 요청 URI입니다.
예 - 오류 페이지 URI가 /ErrorPageApp/ErrorPage이고, 전달할 헤더에 Host가 포함되며 클라이언트가 다음 요청을 전송합니다.
GET  /house/rooms/kitchen.jpg HTTP/1.1
호스트: homeserver.companyx.com
요청 결과는 HTTP 404 응답(로컬 또는 원격)이며 오류 페이지 애플리케이션의 요청 URI는 다음과 같습니다.
/ErrorPageApp/ErrorPage?responseCode=404&uri=/house/rooms/kitchen.jpg&Host= homeserver.companyx.com
오류로 인식될 HTTP 상태 코드
오류 페이지 정책이 응답을 제공할 상태 코드를 지정합니다. 상태 코드를 지정하지 않으면 해당 상태 코드와 함께 응답의 원래 컨텐츠가 리턴됩니다. 지정된 HTTP 상태 코드가 없으면 기본값 404 및 5XX가 사용됩니다. 상태 코드를 개별적으로 지정하지 않고 다음 방법을 사용하여 범위를 표시하는 것이 좋습니다.
  • 5XX: 500-599
  • 4XX: 400-499
  • 3XX: 300-399
  • 2XX: 200-299

사용자 정의 오류 페이지를 미조정할 때 사용할 프록시 사용자 정의 특성: key=http.statuscode.errorPageRedirect. 이 사용자 정의 특성은 오류 페이지 생성이 프록시 오류 페이지 애플리케이션을 사용하는 대신 경로 재지정을 사용하여 수행되는지 여부를 판별합니다. 값은 true 또는 false입니다. 기본값은 false입니다.

정적 파일 제공

프록시 서버가 정적 파일 지원을 수행하는 데 필요한 값을 지정합니다.

정적 파일 문서 루트
파일 시스템에 정적 문서 파일이 있는 위치를 지정합니다.
정보 값
데이터 유형 String
기본값 ${USER_INSTALL_ROOT}/staticContent
컨텐츠 맵핑
특정 파일 확장자의 컨텐츠 유형 맵핑을 지정합니다. 다음 설정에 대해 값을 지정합니다.
정보 값
확장 컨텐츠 유형으로 맵핑할 주제 파일 확장자
헤더 클라이언트로 전송할 헤더 이름
값 클라이언트로 전송할 컨텍스트 유형 헤더의 헤더 값
작업량 이런 확장자를 가진 파일의 순위를 계산하기 위해 사용되는 부동 소수점 값

워크로드 관리

프록시 서버가 워크로드 관리를 수행하는 데 필요한 값을 지정합니다.

고가용성 모니터 제한시간
고가용성 모니터가 제한시간을 초과할 대까지 시간(초)을 지정합니다.
정보 값
데이터 유형 String
단위 초
기본값 300
어드바이저 URI
어드바이저의 URI(Uniform Resource Identifier)를 지정합니다.
정보 값
데이터 유형 String
기본값 /
로드 밸런스 알고리즘
로드 밸런서의 알고리즘을 지정합니다.
정보 값
데이터 유형 String
기본값 공백


파일 이름: ujpx_proxy.html